Typesense - Cluster Provisioning and Configuration Change Issues – Incident details

Cluster Provisioning and Configuration Change Issues

Resolved
Partial outage
Started about 2 months agoLasted about 2 hours

Affected

Cluster Regions

Partial outage from 9:34 AM to 11:29 AM

Oregon

Partial outage from 9:34 AM to 11:29 AM

N Virginia

Partial outage from 9:34 AM to 11:29 AM

Ohio

Partial outage from 9:34 AM to 11:29 AM

Canada

Partial outage from 9:34 AM to 11:29 AM

Sao Paulo

Partial outage from 9:34 AM to 11:29 AM

Updates
  • Resolved
    Resolved

    The issue is now resolved.

    The upstream APIs are now back up and we've verified that new cluster provisioning and configuration changes now work.

  • Identified
    Identified

    We've tracked down the issue and have identified the root cause as originating from our upstream infrastructure provider's APIs being down.

    This is causing any provisioning of new nodes, both during new cluster provisioning and during configuration changes, to be affected.

    Existing clusters that are already provisioned and running are unaffected.

    We are closely monitoring the upstream issue and will post updates as a fix is being worked on.

  • Investigating
    Investigating

    We're investigating reports of issues with cluster provisioning in Typesense Cloud.