[Resolved] Intermittent HTTP 503s with Cloud Dashboard

Started on July 6, 2021 at 1:30 AM. Resolved after about 3 hours

Affected

Management Console
  • Investigating
    July 6, 2021 at 1:30 AM

    When visiting cloud.typesense.org, some users are intermittently seeing HTTP 503s when loading the page. Refreshing the page a few times resolves the issue.

    This only affects the Typesense Cloud management dashboard, and not the actual Typesense Clusters. We are currently investigating this issue.

  • Identified
    July 6, 2021 at 2:00 AM

    We've identified the issue is being caused by an overloaded server. We are working on mitigating the issue.

  • Monitoring
    July 6, 2021 at 2:56 AM

    A fix has been implemented and we are monitoring the results.

  • Resolved
    July 6, 2021 at 4:09 AM

    This incident has been resolved.